Системные требования

Требования к рабочему месту пользователя

Для Linux

Для установки и работы модуля RSclient на рабочем месте пользователя требуется наличие компонентов:

  1. Python версии 3.5 и выше;

  2. Система управления пакетами - pip3;

  3. Клиент удаленного доступа, совместимый с операционной системой, установленной на рабочем месте;

  4. Пакет swig. Для установки пакета выполните команду:

    apt-get install swig
    

На сервере, к которому будет производиться подключение с помощью RSclient, должен быть установлен и настроен сервис RSserver, предоставляющий инфраструктуру управления удаленными рабочими местами.

Для Windows

Поддерживается только 64-разрядная версия Windows.

Для установки и работы модуля RSclient на рабочем месте пользователя требуется наличие компонентов:

  1. Клиент удаленного доступа, совместимый с операционной системой, установленной на рабочем месте;
  2. Распространяемый пакет Visual C++ для Visual Studio 2015.

На сервере, к которому будет производиться подключение с помощью RSclient, должен быть установлен и настроен сервис RSserver, предоставляющий инфраструктуру управления удаленными рабочими местами.

Зависимости

Зависимости после строки # smart card functional не являются обязательными и необходимы только при работе со смарт-картой.

pbr!=2.1.0,>=2.0.0
requests!=2.12.2,!=2.13.0,>=2.10.0
prettytable
cliff>=1.16.0
PySide2<5.12; python_version < '3.6'
PySide2<5.14; python_version >= '3.6'
distro

# smart card functional
pykcs11
pyopenssl
pyasn1